JULY-II-Sprint tickets update
Incident Report for Bectran
Resolved
Updated with JULY-II sprint tickets
Posted Aug 13, 2019 - 07:22 UTC
Investigating
Updating with JULY-II sprint tickets
Posted Aug 13, 2019 - 06:09 UTC
This incident affected: AR & Collections Management, B2B Credit Management, and Customer.