Emergency Issue
Incident Report for Bectran
Resolved
This incident has been resolved.
Posted Sep 29, 2022 - 22:07 UTC
Monitoring
We are monitoring the environment currently
Posted Sep 29, 2022 - 15:56 UTC
Identified
The issue has been identified
Posted Sep 29, 2022 - 15:55 UTC
Update
We are continuing to investigate this issue and trying to get the site back ASAP.
Posted Sep 29, 2022 - 15:27 UTC
Investigating
We are experiencing connectivity delays with our infrastructure service provider. Our team is actively working with the providers to get this resolved. ETA is expected to be 1 hour.
Posted Sep 29, 2022 - 14:31 UTC
This incident affected: AR & Collections Management, B2B Credit Management, Customer, bectran.com, and Infrastructure.