Outlook Email Delivery Issues

Incident Report for Bectran

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 24, 2026 - 04:09 UTC

Investigating

At approximately 5:00 AM CST on January 22, our engineering team identified an email delivery disruption originating from Microsoft’s Outlook consumer email services. As a result, customers may experience elevated blocking rates when sending emails to domains such as Outlook.com and Hotmail.com.
This issue is external to Bectran’s platform. We are coordinating closely with Microsoft while they investigate and work toward a resolution.
Posted Jan 23, 2026 - 23:04 UTC
This incident affects: AR & Collections Management, B2B Credit Management, Customer, and Bureaus.