Third Party Services - Partial Outage

Incident Report for Bectran

Resolved

This incident has been resolved.
Posted Oct 22, 2025 - 15:35 UTC

Monitoring

While Bectran is not affected by the current AWS outage, we are experiencing intermittent connectivity issues with the following third-party services:

1. Experian NetConnect
2. Plaid
3. Secretary of State Verification
4. TIN Verification

More details on the AWS outage can be found here: https://health.aws.amazon.com/health/status

We will continue to monitor and provide updates. Please reach out to us if you have any questions.
Posted Oct 20, 2025 - 18:02 UTC
This incident affected: Bureaus.