USFBridge and SYSCO update
Incident Report for Bectran
Resolved
Updated with SYSCO and USFbridge tickets
Posted Aug 17, 2019 - 08:10 UTC
Investigating
Updating with SYSCO and USFbridge tickets
Posted Aug 17, 2019 - 06:18 UTC
This incident affected: AR & Collections Management, B2B Credit Management, and Customer.