Unexpected Pop-Up Message

Incident Report for Bectran

Resolved

This incident has been resolved.
Posted Sep 10, 2025 - 21:05 UTC

Monitoring

You may have noticed an unexpected pop-up with test verbiage appear briefly while logging in. This was part of an early feature rollout on our end — no action is needed and has been resolved. Thanks for your patience as we fine-tune the experience ahead of full release.
Posted Sep 10, 2025 - 20:54 UTC
This incident affected: B2B Credit Management.