Performance Delays
Incident Report for Bectran
Resolved
The incident has been resolved.
Posted Mar 05, 2024 - 07:51 UTC
Update
The issue has been identified and fixed. We will continue to monitor for the next 12 hours.
Posted Mar 04, 2024 - 20:26 UTC
Monitoring
We are continuing to monitor the system.
Posted Mar 04, 2024 - 19:12 UTC
Identified
Maintenance has been completed. The system is back up and running.
We are continuing to monitor the platform.
Posted Mar 04, 2024 - 16:40 UTC
Update
Emergency maintenance: We are undergoing emergency maintenance and will be restarting our production. Our services will be back shortly.
Posted Mar 04, 2024 - 16:03 UTC
Investigating
We are aware that you have been experiencing performance issues and slow page load times on our platform over the past 1 hour.

Our team is continuing to investigate the root cause of the performance degradation. We will provide updates as necessary.
Posted Mar 04, 2024 - 15:17 UTC
This incident affected: AR & Collections Management, B2B Credit Management, and Customer.