Automated Account Statement Delays

Incident Report for Bectran

Resolved

This incident has been resolved.
Posted Mar 02, 2026 - 20:38 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 02, 2026 - 16:41 UTC

Investigating

We are currently experiencing delays in sending Automated Account Statements to customers for certain scenarios. Any pending statements will be reprocessed once the issue is resolved.
Posted Mar 02, 2026 - 14:23 UTC
This incident affected: AR & Collections Management.