Degraded service – IDM

Incident Report for Bectran

Resolved

This incident has been resolved.
Posted Jan 13, 2026 - 04:28 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 13, 2026 - 01:00 UTC

Update

We are continuing to investigate this issue.
Posted Jan 12, 2026 - 19:02 UTC

Update

AutoPay Issues have been resolved - only email notifications were affected, there were no issues with actual payment processing.

We are continuing to investigate issues with IDM - Auto Approval and will update once identified. All pending requests will be reprocessed once the issue is resolved.
Posted Jan 12, 2026 - 18:57 UTC

Investigating

The team is actively investigating intermittent issues with IDM and automated payments. We will provide further updates once the root cause is identified.
Posted Jan 12, 2026 - 14:41 UTC
This incident affected: AR & Collections Management and B2B Credit Management.