Connectivity Issues
Incident Report for Bectran
Resolved
The Incident has been resolved.
Posted Dec 08, 2023 - 21:47 UTC
Monitoring
The login issue has been resolved, and we are monitoring.
Posted Dec 08, 2023 - 21:28 UTC
Investigating
We are investigating issues with logging on to the system
Posted Dec 08, 2023 - 21:14 UTC
This incident affected: AR & Collections Management, B2B Credit Management, and Customer.